今天准备把springboot项目整合swagger2,来界说接口及其信息,遇到的坑,纪录一下


springboot整合swagger2步骤

1、设置pom.xml


2、建立swagger设置类


3、这启动类中加上注解

@EnableSwagger2


详细若何整合可以百度,资料许多

然后在启动项目的时刻报了下面这个错误:


原因是:

springboot项目整合swagger要注意两者的版本,springboot项目的版本低,响应的swagger版本不能太高


解决方案:

将swagger的版本提升至2.9.2,项目启动OK